Emergency Maintenance: Billing Panel
Incident Report for GlassHost
Resolved
Maintenance is complete.
Posted Nov 30, 2023 - 01:36 UTC
Monitoring
At this time we are performing emergency maintenance on our billing panel. New users are unable to make purchases during this time. Existing customers are not affected.
Posted Nov 29, 2023 - 05:17 UTC
This incident affected: Core Services (Billing).